wxPython Import Module error

A forum for general discussion of the Python programming language.

wxPython Import Module error

Postby linuxdesire » Fri Nov 29, 2013 2:07 am

I have Python 3.3. installed with wxPython_Phoenix 3.0.0.0 -r75187-darwin-py 3.3

I installed the wxPython in the site directory of Python 3.3 I am trying to run a wxPython program that shows a simple frame. But I am getting this error.

Code: Select all
Traceback (most recent call last):
  File "C:\Python33\MyFrame.py", line 2, in <module>
    import wx
  File "C:\Python33\lib\site-packages\wx\__init__.py", line 17, in <module>
    from wx.core import *
  File "C:\Python33\lib\site-packages\wx\core.py", line 6, in <module>
    from ._core import *
ImportError: No module named 'wx._core'


linuxdesire
 
Posts: 9
Joined: Fri Nov 15, 2013 6:45 pm

Re: wxPython Import Module error

Postby octopez » Fri Nov 29, 2013 6:59 am

How did you install it? I thought, Robin Dunn provides a setup.exe for wx (even for Project Phoenix). So the setup does everything for you.
On the other hand: wx for Python > 3.x (called Phoenix) is in development status. It's easily possible that it's just a nightly build and therefore broken.
The stable version of wx is 2.x.x and supports Python 2.

Ah, now I see: why did you install wxPython_Phoenix 3.0.0.0 -r75187-darwin-py 3.3? For Windows of course, you need wxPython_Phoenix ..... win32.exe or wxPython 3....win64.exe!
Darwin is Apple Mac OS X AFAIK!

Do a clean install and use the correct package.
Greetings and all the best,
Octopez

Strange women lying in ponds distributing swords is no basis for a system of government.
User avatar
octopez
 
Posts: 25
Joined: Fri Feb 08, 2013 11:26 pm

Re: wxPython Import Module error

Postby linuxdesire » Fri Nov 29, 2013 4:01 pm

:oops: What a newbie mistake. Ok, I downloaded the wxPython Phoenix-3.0.0.0-r75144-win64-py3.2tar. I have a 64bit OS with windows 7. I extracted it to the site packages directory but still getting the same error. ?
linuxdesire
 
Posts: 9
Joined: Fri Nov 15, 2013 6:45 pm

Re: wxPython Import Module error

Postby octopez » Mon Dec 02, 2013 7:29 am

Sorry for the late reply.

I have a 64bit OS with windows 7.

Ok, but which Python version do you have?
As said before, I recommend a complete new/clean install.

Use Python 3.x for 32 bit and wxPython 32 bit for Python 3.x, and all should be fine.

Keep in mind: Phoenix-3.0.0.0-r75144-win64-py3.2tar - the win64 part corresponds to the installed Python version, NOT the os architecture.
Greetings and all the best,
Octopez

Strange women lying in ponds distributing swords is no basis for a system of government.
User avatar
octopez
 
Posts: 25
Joined: Fri Feb 08, 2013 11:26 pm


Return to General Discussions

Who is online

Users browsing this forum: W3C [Linkcheck] and 2 guests