[SOLVED] tkinter, japanese "kotaeri" input does not work

Post here if you need help with creating a Graphical User Interface in Python.

[SOLVED] tkinter, japanese "kotaeri" input does not work

Postby rovf » Mon Oct 28, 2013 1:24 pm

(Python 2.3.4, OSX 10.4)

For entering Japanese text, I switch my keyboard to the Japanese "kotoeri" input method (http://en.wikipedia.org/wiki/Kotoeri). This doesn't work anymore, when entering the text in a tkinter Entry widget.

The problems are not the characters itself. I can switch the keyboard schema to, say, Greek, and happily enter Greek characters. I can type a Japanese text in an application outside of tkinter (Terminal command line, text editor,...), copy it and paste it into the Entry widget. This all works fine. It is just that I can't type the Japanese text directly into the widget. It is as if the "Kotoeri" input handler is bypassed.

I googled for this problem, and while I didn't find anything special for the Mac, I found one user complaining a very similar problem on Microsoft Windows, where also an input method akin to Kotoeri exists. The culprit in this case was a bug in the Tk libraries.

Is there a similar, known bug in the Tk libraries for this OSX version too?


It is a problem with Tkinter, i.e. it is not designed to run on the Mac yet. A more detailed explanation can be found here: http://forums.devshed.com/python-programming-11/tkinter-japanese-kotaeri-input-method-954173.html#post2933525
Posts: 25
Joined: Fri Aug 16, 2013 4:35 pm

Return to GUI

Who is online

Users browsing this forum: No registered users and 3 guests