PYGAME

This is the place for queries that don't fit in any of the other categories.

PYGAME

Postby iceman2014 » Thu Apr 03, 2014 5:45 pm

Is there a version of pygame that works with python 3.4.0?
Last edited by stranac on Thu Apr 03, 2014 6:36 pm, edited 1 time in total.
Reason: First post lock.
iceman2014
 
Posts: 8
Joined: Wed Apr 02, 2014 9:28 pm

Re: PYGAME

Postby DrakeMagi » Thu Apr 03, 2014 6:52 pm

simple no
maybe try pysfml, pysdl
http://www.python-sfml.org/index.html
Linux: won't find windows here.
Linux: the choice of a GNU generation.
https://github.com/DrakeMagi
DrakeMagi
 
Posts: 113
Joined: Sun May 12, 2013 8:36 pm

Re: PYGAME

Postby stranac » Thu Apr 03, 2014 6:59 pm

Are you sure about that?
Python 3.4 should be compatible with every python 3.x, so pygame should work for it...
Friendship is magic!

R.I.P. Tracy M. You will be missed.
User avatar
stranac
 
Posts: 1155
Joined: Thu Feb 07, 2013 3:42 pm

Re: PYGAME

Postby DrakeMagi » Thu Apr 03, 2014 7:07 pm

pygame has always made 1 version per python version. highest one is 3.2.
and pygame doesn't support python 3.0. it started at 3.1.
and pygame hasn't had updates in a very long time.
since sdl 2.0 came out.
Linux: won't find windows here.
Linux: the choice of a GNU generation.
https://github.com/DrakeMagi
DrakeMagi
 
Posts: 113
Joined: Sun May 12, 2013 8:36 pm

Re: PYGAME

Postby stranac » Thu Apr 03, 2014 7:40 pm

There doesn't have to be an update for it to keep working with backwards-compatible versions.
Anyway, I just tested it(used some of mek's examples), and pygame works on python 3.4 just fine.
Friendship is magic!

R.I.P. Tracy M. You will be missed.
User avatar
stranac
 
Posts: 1155
Joined: Thu Feb 07, 2013 3:42 pm

Re: PYGAME

Postby snippsat » Thu Apr 03, 2014 7:48 pm

User avatar
snippsat
 
Posts: 232
Joined: Thu Feb 21, 2013 12:04 am

Re: PYGAME

Postby metulburr » Thu Apr 03, 2014 8:52 pm

I just installed a fresh arch linux distro, which is using python3.4. I cant seem to get that version to work with pygame at all. The only way i can get arch to run a python3.x version is to downgrade and compile python3.2 and install pygame under that.

Although i have no idea what OS the OP is running under, since he did not mention it. The bitbucket looks to be all windows only.
New Users, Read This
OS Ubuntu 14.04, Arch Linux, Gentoo, Windows 7/8
https://github.com/metulburr
steam
User avatar
metulburr
 
Posts: 1476
Joined: Thu Feb 07, 2013 4:47 pm
Location: Elmira, NY

Re: PYGAME

Postby stranac » Thu Apr 03, 2014 8:54 pm

Weird...
I installed it without a problem on windows, so it definitely works with python 3.4
Friendship is magic!

R.I.P. Tracy M. You will be missed.
User avatar
stranac
 
Posts: 1155
Joined: Thu Feb 07, 2013 3:42 pm

Re: PYGAME

Postby iceman2014 » Thu Apr 03, 2014 9:08 pm

ok thanks a lot for ur help guys much appreciated :)
iceman2014
 
Posts: 8
Joined: Wed Apr 02, 2014 9:28 pm

Re: PYGAME

Postby metulburr » Fri Apr 04, 2014 1:52 am

i figured i would put this for completeness:

I did end up getting python3.4 working with pygame for arch linux.
https://aur.archlinux.org/packages/python-pygame-hg/

Code: Select all
makepkg -s
sudo pacman -U *.xz

Code: Select all
metulburr@rch ~/Downloads/python-pygame-hg $ python
Python 3.4.0 (default, Mar 17 2014, 23:20:09)
[GCC 4.8.2 20140206 (prerelease)] on linux
Type "help", "copyright", "credits" or "license" for more information.
>>> import pygame
>>> exit()
metulburr@rch ~/Downloads/python-pygame-hg $


I also threw this same post up on my pygame3.x tutoiral as i dont wnat to repeat this again, and i tend to reinstall arch quite often.

EDIT:
actually looking deeper into it, it does look like bitbuckets does support linux
New Users, Read This
OS Ubuntu 14.04, Arch Linux, Gentoo, Windows 7/8
https://github.com/metulburr
steam
User avatar
metulburr
 
Posts: 1476
Joined: Thu Feb 07, 2013 4:47 pm
Location: Elmira, NY

Re: PYGAME

Postby snippsat » Fri Apr 04, 2014 2:38 am

---
User avatar
snippsat
 
Posts: 232
Joined: Thu Feb 21, 2013 12:04 am

Re: PYGAME

Postby iceman2014 » Fri Apr 04, 2014 3:40 am

i was trying to run 64 bit windows 7 for version 3.4.0 but pygame isn't working as ive tried all the necessary commands, paths etc and still came up with errors.
The documentation comes up fine, but trying to run the example games doesn't :/
iceman2014
 
Posts: 8
Joined: Wed Apr 02, 2014 9:28 pm

Re: PYGAME

Postby Mekire » Fri Apr 04, 2014 4:28 am

The examples you are trying to run could very well be the issue then. WHere is the exact example you are running, and what is the exact error you are getting. Please post using code tags.

-Mek
User avatar
Mekire
 
Posts: 988
Joined: Thu Feb 07, 2013 11:33 pm
Location: Amakusa, Japan


Return to General Coding Help

Who is online

Users browsing this forum: mdovey, snippsat, W3C [Linkcheck] and 4 guests